import Foundation
let pattern = #"acestream://[a-zA-Z0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"acestream://77f890b8dbc45e57bc145d0ee2c9eb381ff8e1ee acestream://ccba28e0ec6b5e09584dfcf80bcafa070bfe27b1 acestream://ad0de24741ba397708f6d4b0bc87a9e54a2c3331 acestream://679b815c666b89345ae5ef64a69203dec269f09f acestream://bec284c6636fd196bea5fc4186de96dfa94f79a1 acestream://d72ebe51dd14bad45ff011364ff06cd219795fc5 acestream://8c0b73b9ba6cc1b25195d5880f7c4796f007c7da acestream://2dfe474e6520f6015b8d2268476059756eb02d6e acestream://67ffc1f4f16b6b0b1f4113f76e37b6637249452c"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)