import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=申請番号\\s)\\d{4}\\W\\D{2}\\W\\d+\\D";
final String string = "委託(申請番号 2022-AA-000A )//A/F0.f?p2=11@令和4年度業務委託(申請番号 2022-BB-0000e 申請)”\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}