const regex = /(?<=申請番号\s)\d{4}\W\D{2}\W\d+\D/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=申請番号\\s)\\d{4}\\W\\D{2}\\W\\d+\\D', 'gm')
const str = `委託(申請番号 2022-AA-000A )//A/F0.f?p2=11@令和4年度業務委託(申請番号 2022-BB-0000e 申請)”
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}