$re = '/(?<=申請番号\s)\d{4}\W\D{2}\W\d+\D/m';
$str = '委託(申請番号 2022-AA-000A )//A/F0.f?p2=11@令和4年度業務委託(申請番号 2022-BB-0000e 申請)”
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);