package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:['-]\w+)?|[^\w\s]|_`)
var str = `"The element with the longest half-life is Uranium-234" said the professor.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}