$re = '/\w+(?:[\'-]\w+)?|[^\w\s]|_/m';
$str = '"The element with the longest half-life is Uranium-234" said the professor.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);