re = /\w+(?:['-]\w+)?|[^\w\s]|_/m
str = '"The element with the longest half-life is Uranium-234" said the professor.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end