#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)⏰ Timeframe M5\s*((?:\n(?!⏰).*)+)\n⏰ Timeframe M15\b"
Local $sString = "💎 SINAIS VIP - GOLD 🔥:" & @CRLF & _
"⏰ O horário dos sinais é o momento de entrada. O tempo de expiração está no começo do sinal. Entre 2 segundos antes para evitar delay" & @CRLF & _
"" & @CRLF & _
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -" & @CRLF & _
"🔔 Sinais para o dia 06/02/23" & @CRLF & _
"- - - - - - - - - - - - - - - - - - - - - - - - - - - -" & @CRLF & _
"" & @CRLF & _
"SINAIS SEM MARTINGALE" & @CRLF & _
"" & @CRLF & _
"⏰ Timeframe M5" & @CRLF & _
"" & @CRLF & _
"04:05 - EURUSD - PUT " & @CRLF & _
"04:05 - gbpchf - PUT " & @CRLF & _
"06:35 - EURGBP - PUT " & @CRLF & _
"07:10 - EURUSD - PUT️ " & @CRLF & _
"08:15 - EURJPY - PUT " & @CRLF & _
"08:45 - EURGBP - PUT " & @CRLF & _
"09:55 - EURUSD - PUT " & @CRLF & _
"09:10 - AUDJPY - PUT " & @CRLF & _
"10:55 - AUDUSD - PUT️ " & @CRLF & _
"11:10 - USDCAD - PUT " & @CRLF & _
"12:55 : AUDCAD - PUT️ " & @CRLF & _
"14:15 - EURUSD - PUT " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"⏰ Timeframe M15" & @CRLF & _
"" & @CRLF & _
"04:30 - EURUSD - PUT️ " & @CRLF & _
"05:30 - AUDCAD - PUT " & @CRLF & _
"06:15 - EURGBP - PUT " & @CRLF & _
"07:15 - EURUSD - CALL " & @CRLF & _
"08:00 - GBPJPY - CALL " & @CRLF & _
"10:15 - EURUSD - CALL " & @CRLF & _
"11:00 - AUDUSD - PUT" & @CRLF & _
"11:45 - EURJPY - PUT " & @CRLF & _
"12:30 - EURUSD - PUT " & @CRLF & _
"14:45 - EURUSD - PUT " & @CRLF & _
"" & @CRLF & _
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -" & @CRLF & _
"⚠️ Não opere contra a tendência" & @CRLF & _
"" & @CRLF & _
"Cadastre-se na quotex é ganhe um bônus de deposito sobre o seu valor." & @CRLF & _
"" & @CRLF & _
"https://quotex.io/sign-up/fast/?lid=61838" & @CRLF & _
"quotex.io" & @CRLF & _
"Quotex: An innovative platform for online investment" & @CRLF & _
"Quotex is an innovative platform with up to 98% return on every investment! Sign up for a demo account to practice with $10,000. With a minimum deposi..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")