import Foundation
let pattern = #"⏰ Timeframe M5\s*((?:\n(?!⏰).*)+)\n⏰ Timeframe M15\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
💎 SINAIS VIP - GOLD 🔥:
⏰ O horário dos sinais é o momento de entrada. O tempo de expiração está no começo do sinal. Entre 2 segundos antes para evitar delay
- - - - - - - - - - - - - -- - - - - - - - - - - - - -
🔔 Sinais para o dia 06/02/23
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
SINAIS SEM MARTINGALE
⏰ Timeframe M5
04:05 - EURUSD - PUT
04:05 - gbpchf - PUT
06:35 - EURGBP - PUT
07:10 - EURUSD - PUT️
08:15 - EURJPY - PUT
08:45 - EURGBP - PUT
09:55 - EURUSD - PUT
09:10 - AUDJPY - PUT
10:55 - AUDUSD - PUT️
11:10 - USDCAD - PUT
12:55 : AUDCAD - PUT️
14:15 - EURUSD - PUT
⏰ Timeframe M15
04:30 - EURUSD - PUT️
05:30 - AUDCAD - PUT
06:15 - EURGBP - PUT
07:15 - EURUSD - CALL
08:00 - GBPJPY - CALL
10:15 - EURUSD - CALL
11:00 - AUDUSD - PUT
11:45 - EURJPY - PUT
12:30 - EURUSD - PUT
14:45 - EURUSD - PUT
- - - - - - - - - - - - - -- - - - - - - - - - - - - -
⚠️ Não opere contra a tendência
Cadastre-se na quotex é ganhe um bônus de deposito sobre o seu valor.
https://quotex.io/sign-up/fast/?lid=61838
quotex.io
Quotex: An innovative platform for online investment
Quotex is an innovative platform with up to 98% return on every investment! Sign up for a demo account to practice with $10,000. With a minimum deposi...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)