# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"⏰ Timeframe M5\s*((?:\n(?!⏰).*)+)\n⏰ Timeframe M15\b"
test_str = ("💎 SINAIS VIP - GOLD 🔥:\n"
"⏰ O horário dos sinais é o momento de entrada. O tempo de expiração está no começo do sinal. Entre 2 segundos antes para evitar delay\n\n"
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -\n"
"🔔 Sinais para o dia 06/02/23\n"
"- - - - - - - - - - - - - - - - - - - - - - - - - - - -\n\n"
"SINAIS SEM MARTINGALE\n\n"
"⏰ Timeframe M5\n\n"
"04:05 - EURUSD - PUT \n"
"04:05 - gbpchf - PUT \n"
"06:35 - EURGBP - PUT \n"
"07:10 - EURUSD - PUT️ \n"
"08:15 - EURJPY - PUT \n"
"08:45 - EURGBP - PUT \n"
"09:55 - EURUSD - PUT \n"
"09:10 - AUDJPY - PUT \n"
"10:55 - AUDUSD - PUT️ \n"
"11:10 - USDCAD - PUT \n"
"12:55 : AUDCAD - PUT️ \n"
"14:15 - EURUSD - PUT \n\n\n"
"⏰ Timeframe M15\n\n"
"04:30 - EURUSD - PUT️ \n"
"05:30 - AUDCAD - PUT \n"
"06:15 - EURGBP - PUT \n"
"07:15 - EURUSD - CALL \n"
"08:00 - GBPJPY - CALL \n"
"10:15 - EURUSD - CALL \n"
"11:00 - AUDUSD - PUT\n"
"11:45 - EURJPY - PUT \n"
"12:30 - EURUSD - PUT \n"
"14:45 - EURUSD - PUT \n\n"
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -\n"
"⚠️ Não opere contra a tendência\n\n"
"Cadastre-se na quotex é ganhe um bônus de deposito sobre o seu valor.\n\n"
"https://quotex.io/sign-up/fast/?lid=61838\n"
"quotex.io\n"
"Quotex: An innovative platform for online investment\n"
"Quotex is an innovative platform with up to 98% return on every investment! Sign up for a demo account to practice with $10,000. With a minimum deposi...")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.