import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[sS]ee, e\\.g\\.,.*?(?:\\(D\\.C\\. Cir\\..*(?:(\\(11th Cir\\.)|((\\(10th Cir\\.)|((\\(9th Cir\\.)|((\\(8th Cir\\.)|((\\(7th Cir\\.)|((\\(6th Cir\\.)|((\\(5th Cir\\.)|((\\(4th Cir\\.)|((\\(3d Cir\\.)|((\\(2d Cir\\.)|(\\(1st Cir\\.)))))))))))|(?1).*(?2)|(?3).*(?4)|(?5).*(?6)|(?7).*(?8)|(?9).*(?10)|(?11).*(?12)|(?13).*(?14)|(?15).*(?16)|(?17).*(?18)|(?19).*(?20)).*\\.";
final String string = "See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017).\n\n"
+ "See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).\n"
+ "See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017).\n\n\n"
+ "See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).\n\n"
+ "See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).\n"
+ "See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}