# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[sS]ee, e\.g\.,.*?(?:\(D\.C\. Cir\..*(?:(\(11th Cir\.)|((\(10th Cir\.)|((\(9th Cir\.)|((\(8th Cir\.)|((\(7th Cir\.)|((\(6th Cir\.)|((\(5th Cir\.)|((\(4th Cir\.)|((\(3d Cir\.)|((\(2d Cir\.)|(\(1st Cir\.)))))))))))|(?1).*(?2)|(?3).*(?4)|(?5).*(?6)|(?7).*(?8)|(?9).*(?10)|(?11).*(?12)|(?13).*(?14)|(?15).*(?16)|(?17).*(?18)|(?19).*(?20)).*\."
test_str = ("See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017).\n\n"
"See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).\n"
"See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017).\n\n\n"
"See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).\n\n"
"See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).\n"
"See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.