use strict;
my $str = 'See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017).
See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).';
my $regex = qr/[sS]ee, e\.g\.,.*?(?:\(D\.C\. Cir\..*(?:(\(11th Cir\.)|((\(10th Cir\.)|((\(9th Cir\.)|((\(8th Cir\.)|((\(7th Cir\.)|((\(6th Cir\.)|((\(5th Cir\.)|((\(4th Cir\.)|((\(3d Cir\.)|((\(2d Cir\.)|(\(1st Cir\.)))))))))))|(?1).*(?2)|(?3).*(?4)|(?5).*(?6)|(?7).*(?8)|(?9).*(?10)|(?11).*(?12)|(?13).*(?14)|(?15).*(?16)|(?17).*(?18)|(?19).*(?20)).*\./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}