#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/(?:www\.)?kuula.co\/share\/(?:[A-Za-z0-9]+\/)?(?:collection\/)?([A-Za-z0-9]+)(\?.*)?$"
Local $sString = "https://kuula.co" & @CRLF & _
"https://kuula.co/about" & @CRLF & _
"https://kuula.co/post" & @CRLF & _
"https://kuula.co/share" & @CRLF & _
"https://kuula.co/share/39u4$" & @CRLF & _
"https://kuula.co/post/7qQZ7" & @CRLF & _
"https://kuula.co/post/7qQZ7/collection/7lPZ8" & @CRLF & _
"http://kuula.co/share/7qQZ7" & @CRLF & _
"https://kuula.co/share/7qQZ7" & @CRLF & _
"https://kuula.co/share/collection/7lPZ8" & @CRLF & _
"https://kuula.co/share/7qQZ7?fs=1&abc=10" & @CRLF & _
"https://kuula.co/share/7qQZ7/collection/7lPZ8" & @CRLF & _
"https://kuula.co/share/collection/7lPZ8?vr=0" & @CRLF & _
"https://www.kuula.co/share/7qQZ7?abc=1" & @CRLF & _
"https://another-page.net/share/7qQZ7" & @CRLF & _
"https://kuula.co.another-page.com/share/7qQZ7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")