import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(?:www\\.)?kuula.co\\/share\\/(?:[A-Za-z0-9]+\\/)?(?:collection\\/)?([A-Za-z0-9]+)(\\?.*)?$";
final String string = "https://kuula.co\n"
+ "https://kuula.co/about\n"
+ "https://kuula.co/post\n"
+ "https://kuula.co/share\n"
+ "https://kuula.co/share/39u4$\n"
+ "https://kuula.co/post/7qQZ7\n"
+ "https://kuula.co/post/7qQZ7/collection/7lPZ8\n"
+ "http://kuula.co/share/7qQZ7\n"
+ "https://kuula.co/share/7qQZ7\n"
+ "https://kuula.co/share/collection/7lPZ8\n"
+ "https://kuula.co/share/7qQZ7?fs=1&abc=10\n"
+ "https://kuula.co/share/7qQZ7/collection/7lPZ8\n"
+ "https://kuula.co/share/collection/7lPZ8?vr=0\n"
+ "https://www.kuula.co/share/7qQZ7?abc=1\n"
+ "https://another-page.net/share/7qQZ7\n"
+ "https://kuula.co.another-page.com/share/7qQZ7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}