#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{3,4}$"
Local $sString = "025" & @CRLF & _
"9876" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"98" & @CRLF & _
"98765" & @CRLF & _
" 000" & @CRLF & _
"000 " & @CRLF & _
"02a" & @CRLF & _
"2a2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")