import re
regex = re.compile(r"^\d{3,4}$", flags=re.MULTILINE)
test_str = ("025\n"
"9876\n\n\n"
"98\n"
"98765\n"
" 000\n"
"000 \n"
"02a\n"
"2a2\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")