using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{1,40}$)[a-zA-Z]+(?:[\s]+([a-zA-Z]*)?+)*$";
string input = @"sdfsdf sdd dssadfsddsfadsf adsfsdaf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}