re = /^(?=.{1,40}$)[a-zA-Z]+(?:[\s]+([a-zA-Z]*)?+)*$/m
str = 'sdfsdf sdd dssadfsddsfadsf adsfsdaf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end