$re = '/^(?=.{1,40}$)[a-zA-Z]+(?:[\s]+([a-zA-Z]*)?+)*$/m';
$str = 'sdfsdf sdd dssadfsddsfadsf adsfsdaf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);