#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?<real>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?(?:[+\-]))?(?<imaginary>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?[iI]$"
Local $sString = "1.23e+45-67.89e-1256i" & @CRLF & _
"3" & @CRLF & _
"3+4i" & @CRLF & _
"3+4I" & @CRLF & _
"3-4i" & @CRLF & _
"+4i" & @CRLF & _
"-2i" & @CRLF & _
"3+i" & @CRLF & _
"4-i" & @CRLF & _
"+i" & @CRLF & _
"-i" & @CRLF & _
"i"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")