re = /^(?:(?<real>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?(?:[+\-]))?(?<imaginary>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?[iI]$/m
str = '1.23e+45-67.89e-1256i
3
3+4i
3+4I
3-4i
+4i
-2i
3+i
4-i
+i
-i
i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end