package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<real>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?(?:[+\-]))?(?<imaginary>\d+(?:(?:\.\d+)?(?:e[+\-]\d+)?)?)?[iI]$`)
var str = `1.23e+45-67.89e-1256i
3
3+4i
3+4I
3-4i
+4i
-2i
3+i
4-i
+i
-i
i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}