#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^[Cc])[1-9a-fA-F]+(?=[Pp]([1-9a-fA-F]+$))"
Local $sString = "c45AFP2" & @CRLF & _
"CAPF" & @CRLF & _
"c56Bp26" & @CRLF & _
"CA6C22pAAA" & @CRLF & _
"BCA6C22pAAA" & @CRLF & _
"c56Bp" & @CRLF & _
"c45AF0P2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")