$re = '/(?<=^[Cc])[1-9a-fA-F]+(?=[Pp]([1-9a-fA-F]+$))/m';
$str = 'c45AFP2
CAPF
c56Bp26
CA6C22pAAA
BCA6C22pAAA
c56Bp
c45AF0P2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);