import re
regex = re.compile(r"(?<=^[Cc])[1-9a-fA-F]+(?=[Pp]([1-9a-fA-F]+$))", flags=re.MULTILINE)
test_str = ("c45AFP2\n"
"CAPF\n"
"c56Bp26\n"
"CA6C22pAAA\n"
"BCA6C22pAAA\n"
"c56Bp\n"
"c45AF0P2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")