import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"(*SKIP)(*F)|\\{\\{[^\\}\\{]+\\}\\}";
final String string = "Lorem ipsum {{ var1 }} dolar epsum <a href=\"{{ var2 }}\">solar</a> hello goodbye. {{var3}} var {{ var4 }}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}