// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]*"(*SKIP)(*F)|{{[^}{]+}}"#).unwrap();
let string = "Lorem ipsum {{ var1 }} dolar epsum <a href=\"{{ var2 }}\">solar</a> hello goodbye. {{var3}} var {{ var4 }}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}