re = /"[^"]*"(*SKIP)(*F)|{{[^}{]+}}/m
str = 'Lorem ipsum {{ var1 }} dolar epsum <a href="{{ var2 }}">solar</a> hello goodbye. {{var3}} var {{ var4 }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end