$re = '/.*<body onload="init(0,0);">.*/m';
$str = 'Hello <body onload="init(0,0);"> there';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);