re = /.*<body onload="init(0,0);">.*/m
str = 'Hello <body onload="init(0,0);"> there'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end