using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\^{1,}([0-7]){1,})([a-zA-Z]*)";
string input = @"^1Piros^^2Zold^^10Sarga";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}