// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\^{1,}([0-7]){1,})([a-zA-Z]*)").unwrap();
let string = "^1Piros^^2Zold^^10Sarga";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}