$re = '/(\^{1,}([0-7]){1,})([a-zA-Z]*)/';
$str = '^1Piros^^2Zold^^10Sarga';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);