use strict;
my $str = 'afwqf&1drghreh
afwqf&fdrghreh';
my $regex = qr/&\w/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";