const regex = /^(?=[^a-z]*[a-z])(?=(?:\D*\d){9})[a-z\d ]{12,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^a-z]*[a-z])(?=(?:\\D*\\d){9})[a-z\\d ]{12,}$', 'gm')
const str = `f8a9s890f faf980dfd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}