$re = '/^(?=[^a-z]*[a-z])(?=(?:\D*\d){9})[a-z\d ]{12,}$/m';
$str = 'f8a9s890f faf980dfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);