re = /^(?=[^a-z]*[a-z])(?=(?:\D*\d){9})[a-z\d ]{12,}$/m
str = 'f8a9s890f faf980dfd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end