#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"(?=.*"$)|\G(?!^))(~?@\w+(?:,~?@\w+)*)"?[,\h]?"
Local $sString = ""@smoke"" & @CRLF & _
""@smoke,@Functional1"" & @CRLF & _
""@smoke,@Functional1,@Functional2"" & @CRLF & _
""@smoke","@Functional1"" & @CRLF & _
""@smoke","~@Functional1"" & @CRLF & _
""~@smoke","~@Functional1""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")