using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""(?=.*""$)|\G(?!^))(~?@\w+(?:,~?@\w+)*)""?[,\h]?";
string input = @"""@smoke""
""@smoke,@Functional1""
""@smoke,@Functional1,@Functional2""
""@smoke"",""@Functional1""
""@smoke"",""~@Functional1""
""~@smoke"",""~@Functional1""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}