$re = '/(?:"(?=.*"$)|\G(?!^))(~?@\w+(?:,~?@\w+)*)"?[,\h]?/m';
$str = '"@smoke"
"@smoke,@Functional1"
"@smoke,@Functional1,@Functional2"
"@smoke","@Functional1"
"@smoke","~@Functional1"
"~@smoke","~@Functional1"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);