package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(?:_{0,2}[a-z]+)*$`)
var str = `a
long
list
of
strings
that
do
not
meet
the
question
criteria
this_works`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}