re = /^[a-z]+(?:_{0,2}[a-z]+)*$/m
str = 'a
long
list
of
strings
that
do
not
meet
the
question
criteria
this_works'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end