$re = '/^[a-z]+(?:_{0,2}[a-z]+)*$/m';
$str = 'a
long
list
of
strings
that
do
not
meet
the
question
criteria
this_works';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);