const regex = /[+]{0,1}[0-9]{2,4}[\s\.-]{0,}[0-9]{3}[\s\.-]{0,}[0-9]{3}\s{0,}[0-9]{0,3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+]{0,1}[0-9]{2,4}[\\s\\.-]{0,}[0-9]{3}[\\s\\.-]{0,}[0-9]{3}\\s{0,}[0-9]{0,3}', 'g')
const str = `0700 - 000 000
+46 000 - 000 000
+46-000 - 000 000
+46.000 - 000 000
0046 000 - 000 000
0046-000 - 000 000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}