import re
regex = re.compile(r"[+]{0,1}[0-9]{2,4}[\s\.-]{0,}[0-9]{3}[\s\.-]{0,}[0-9]{3}\s{0,}[0-9]{0,3}")
test_str = ("0700 - 000 000\n"
"+46 000 - 000 000\n"
"+46-000 - 000 000\n"
"+46.000 - 000 000\n"
"0046 000 - 000 000\n"
"0046-000 - 000 000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")