$re = '/[+]{0,1}[0-9]{2,4}[\s\.-]{0,}[0-9]{3}[\s\.-]{0,}[0-9]{3}\s{0,}[0-9]{0,3}/';
$str = '0700 - 000 000
+46 000 - 000 000
+46-000 - 000 000
+46.000 - 000 000
0046 000 - 000 000
0046-000 - 000 000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);