using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1-?1-?1-?1-?2-?2-?2-?2";
string input = @"1111-2222 and 11112222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}