const regex = /\B(?=\d*\.)(?=(\d{3})+(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?=\\d*\\.)(?=(\\d{3})+(?!\\d))', 'gm')
const str = `803427325.0326`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);