use strict;
my $str = '803427325.0326';
my $regex = qr/\B(?=\d*\.)(?=(\d{3})+(?!\d))/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";